AAA与RADIUS应用一login登录服务验证

  • A+
所属分类:编程

AAA与RADIUS应用一login登录服务验证
AAA与RADIUS应用一login登录服务验证

1、 根据拓扑连接设备,并设置IP地址及网关
2、 配置RADIUS服务
AAA与RADIUS应用一login登录服务验证

RADIUS服务器配置参数:
客户端地址为200.1.1.1,客户端名称为R1,与NAS服务器的口令是666,servertype为RADIUS.
用户设置:
用户名为bbb,密码为222。
注意NAS路由器上的主机名为R1,配置口令和RADIUS服务器上的口令一定要一致即可。
3、 NAS服务器上的配置(路由器配置)
Router>enable
Router#configure terminal
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 192.168.1.254 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface FastEthernet0/1
Router(config-if)#ip address 200.1.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)# exit
Router(config)#
Router(config)#hostname R1
R1(config)#aaa new-model 启用AAA安全模型
R1(config)#username 123 password 333 设置本地用户名和密码

R1(config)#aaa authentication login test group radius local
定义验证方法列表名称为test,用户行为为login,验证方法1为服务器验证,失败后用local验证。
R1(config)#line vty 0 4
R1(config-line)#login authentication test 应用验证方法列表到0-4线路上
R1(config-line)#exit
R1(config)#radius-server host 200.1.1.2 指明RADIUS服务的地址
R1(config)#radius-server key 666 定义与服务器之间的口令

在PC端验证实验;
AAA与RADIUS应用一login登录服务验证

制造故障,把连接服务器的端口关闭

R1(config)#interface FastEthernet0/1
R1(config-if)#shutdown
R1(config-if)#exit

AAA与RADIUS应用一login登录服务验证

当服务器的链路故障后 ,在用服务器上的用户名和密码做验证必然失败,失败后可以用本地验证,123密码333是路由器的用户名和密码,即local验证成功。


 

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: